微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

B - Dropping tests

In a certain course,you take n tests. If you get ai out of bi questions correct on test i,your cumulative average is defined to be

分享图片

.

Given your test scores and a positive integer k,determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5,0/1,and 2/6. Without dropping any tests,your cumulative average is 

分享图片

. However,if you drop the third test,your cumulative average becomes 

分享图片

.

Input

The input test file will contain multiple test cases,each containing exactly three lines. The first line contains two integers,1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains npositive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1,000,000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case,write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors,the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e.,you can assume that the average is never 83.4997).

 

分享图片

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <cmath>
using namespace std;
#define eps 1e-7
int n,k;
double a[2005],b[2005],t[2005];

double gh(double x)
{
    for(int i=0;i<n;i++)
        t[i]=a[i]-x*b[i];
    sort(t,t+n);
    double ans=0;
    for(int i=k;i<n;i++)
        ans+=t[i];
    return ans;
}

int main()
{
    while(scanf("%d %d",&n,&k))
    {
        if(n==0&&k==0) break;
        for(int i=0;i<n;i++)
            scanf("%lf",&a[i]);
        for(int i=0;i<n;i++)
            scanf("%lf",&b[i]);
        double l=0.0,r=1.0,mid;
        while(r-l>eps)
        {
            mid=(l+r)/2;
            if(gh(mid)>0) l=mid;
            else r=mid;
        }
        printf("%1.f\n",l*100);
    }
    return 0;
}
View Code

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐