微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

杭电-2674N!Again大数阶乘

N!Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4267    Accepted Submission(s): 2279


Problem Description
WhereIsHeroFrom:             Zty,what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1,N! = N*(N-1)!
 

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
 

Output
For each case,output N! mod 2009
 

Sample Input
  
  
4 5
 

Sample Output
  
  
24 120
 


大数阶乘,但是规律是41及其以后取余2009都为0,一定要优化这一句,否则超时



#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
long long solve(long long  n)
{
	long long t=1;
	for(long long i=n;i>=2;i--)
		t=i*t%2009;
	return t;
}
int main()
{
	long long a,n,i;
	while(scanf("%lld",&n)!=EOF)
	{
		if(n>=41)
		printf("0\n");
		else
		{
			a=solve(n);
			printf("%lld\n",a);
		}
	}
	return 0;
}

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐