微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

hdu 1047 Integer Inquiry 大数相加


Problem Description
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking varIoUs sums of those numbers. 
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment,once one became available on the third floor of the Lemon Sky apartments on Third Street.) 
 

Input
The input will consist of at most 100 lines of text,each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length,and will only contain digits (no VeryLongInteger will be negative). 

The final input line will contain a single zero on a line by itself.
 

Output
Your program should output the sum of the VeryLongIntegers given in the input. 


This problem contains multiple test cases!

The first line of a multiple input is an integer N,then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Sample Input
  
  
1 123456789012345678901234567890 123456789012345678901234567890 123456789012345678901234567890 0
 

Sample Output
  
  
370370367037037036703703703670


题意: 一开始没看懂题目以为0代表整个程序输入结束,其实是标志了一个测试用例的结束。从这道题可以总结出一个规律:input部分描述的是一个测试用例的情况。如果题目中有This problem contains multiple test cases之类的话,表示有多个用例。

思路:核心的大数相加算法 : 每次读入一行数字到数组a中,然后从个位到高位将a的每个数字加到sum数组中。需要注意的是当a的每一位都加了后如果还有进位,要对每一位都进行处理,而不是只处理一次,因为可能会不断的向前进位。

代码

#include <stdio.h>
#include <string.h>
#define N 105
char a[N],sum[N]; int  t,i,j,up,len; int main() {
    scanf("%d",&t); for(i=0; i<t; i++) {
        memset(sum,0,sizeof(sum)); do {
            scanf("%s",a); if(strcmp(a,"0")==0) {
                len=N-1; while(!sum[len]&&len>=0)len--; if(len==-1)printf("0"); for(j=len; j>=0; j--)printf("%d",sum[j]); break; }
            len=strlen(a);
            up=0; for(j=len-1; j>=0; j--) {
                sum[(len-1)-j] =up + sum[(len-1)-j] + (a[j]-'0') ;
                up=sum[(len-1)-j]/10;
                sum[(len-1)-j]%=10; } if(up) { for(; len-1-j<N; j--) {
                    sum[(len-1)-j]=up+sum[(len-1)-j];
                    up=sum[(len-1)-j]/10;
                    sum[(len-1)-j]%=10; } } } while(1);
        i!=t-1?printf("\n\n"):printf("\n"); } return 0; }

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐