微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

Hat's Fibonacci 1250 (大数+数学 好题)

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9381    Accepted Submission(s): 3060


Problem Description
A Fibonacci sequence is calculated by adding the prevIoUs two members the sequence,with the first two members being both 1.
F(1) = 1,F(2) = 1,F(3) = 1,F(4) = 1,F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input,and print that Fibonacci number.
 

Input
Each line will contain an integers. Process to end of file.
 

Output
For each case,output the result in a line.
 

Sample Input
  
  
100
 

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data,ie. F(20) = 66526 has 5 digits.
#include<stdio.h>
#include<string.h>
int a[10100][510];
int main()
{
	int n,i,j;
	a[1][0]=a[2][0]=a[3][0]=a[4][0]=1;
	for(i=5;i<=10000;i++)
	{
		for(j=0;j<=500;j++)
			a[i][j]=a[i-1][j]+a[i-2][j]+a[i-3][j]+a[i-4][j];
		for(j=0;j<=500;j++)
		{
			if(a[i][j]>=1000000)
			{
				a[i][j+1]+=a[i][j]/1000000;
				a[i][j]%=1000000;
			}
		}
	}
	while(scanf("%d",&n)!=EOF)
	{
		i=500;
		while(a[n][i]==0)
			i--;
			printf("%d",a[n][i]);
		while(--i>=0)
			printf("%06d",a[n][i]);
		printf("\n");
	}
	return 0;
}

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐