A + B Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 264743 Accepted Submission(s): 51237
Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case,you should output two lines. The first line is “Case #:”,# means the number of the test case. The second line is the an equation “A + B = Sum”,Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
简单大数:模拟手算。
为了便于计算,要将两个整数读成字符串,并且倒置(也有防止加法溢出额情况)
ac代码
#include <stdio.h>
#include <cstring>
#define maxn 1000
char a[maxn];
char b[maxn];
char c[maxn+3];
void change(char a[]){
int len=strlen(a);
for(int i=0;i==0||i<len/2;i++){
int temp;
temp=a[i]-'0';
a[i]=a[len-i-1]-'0';
a[len-i-1]=temp;
}
if((len%2)==1)
a[len/2]=a[len/2]-'0';
}
void tsum(char a[],char b[],char c[]){
int yu=0;
int temp=0;
for(int i=0;i<maxn;i++){
temp=a[i]+b[i]+yu;
c[i]=temp%10;
yu=temp/10;
}
}
int main(){
int n;
while(scanf("%d",&n)!=EOF){
int ca=1;
int first=0;
while(n--){
memset(a,0,sizeof(a));
memset(b,sizeof(b));
if(first){
printf("\n");
}else{
first=1;
}
printf("Case %d:\n",ca++);
scanf("%s%s",a,b);
printf("%s + %s = ",b);
change(a);
change(b);
tsum(a,b,c);
int start=0;
for(start=maxn-1;c[start]==0;start--);
for(;start>=0;start--)
printf("%d",c[start]);
printf("\n");
}
}
return 0;
}
版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。