微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

Children’s Queue 1297 大数

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12453    Accepted Submission(s): 4066


Problem Description
There are many students in PHT School. One day,the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words,either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF,FFFM,MFFF,FFMM,MFFM,MMFF,MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
 

Input
There are multiple cases in this problem and ended by the EOF. In each case,there is only one integer n means the number of children (1<=n<=1000)
 

Output
For each test case,there is only one integer means the number of queue satisfied the headmaster’s needs.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 4
 
//现列举前几项,找出规律,a[i]=a[i-1]+a[i-2]+a[i-4].......
//然后就是一大数模板了。 
#include<stdio.h>
#include<string.h>
int a[1010][1010];
int main(){
	int i,j,n,m;
	a[0][1000]=0;a[1][1000]=1;a[2][1000]=2;a[3][1000]=4;a[4][1000]=7;
	for(i=5;i<=1000;i++)
	{
		for(j=1000;j>=0;j--)
		{
			a[i][j]+=a[i-1][j]+a[i-2][j]+a[i-4][j];
			if(a[i][j]>=10)
			{
				a[i][j-1]+=a[i][j]/10;
				a[i][j]=a[i][j]%10;
			}
		}
	}
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<=1000;i++)
			if(a[n][i]!=0)
				break;
			m=i;
		for(i=m;i<=1000;i++)
			printf("%d",a[n][i]);
			printf("\n");
	}
	return 0;
}

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐