微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

poj2506 大数递推

Tiling
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8205   Accepted: 3974

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?
Here is a sample tiling of a 2x17 rectangle.


Input

Input is a sequence of lines,each line containing an integer number 0 <= n <= 250.

Output

For each line of input,output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

Source

The UofA Local 2000.10.14
#include<iostream>
#include<cstring>
#include<cstdio>

using namespace std;

int main()
{
    int a[300][200];
    memset(a,sizeof(a));
    a[0][0]=1;
    a[1][0]=1;
    a[2][0]=3;
    for(int i=3; i<=250; i++)
    {
        for(int j=0; j<=100; j++)
        {
            a[i][j]+=(a[i-1][j]+a[i-2][j]+a[i-2][j]);
            if(a[i][j]>=10)
            {
                int t=a[i][j];
                a[i][j]%=10;
                a[i][j+1]+=t/10;
            }
        }
    }
    int n;
    while(cin>>n)
    {
        if(n==0)
            cout<<1<<endl;
        else
        {
            int i=100;
            while(!a[n][i])
            {
                i--;
            }
            for(int j=i; j>=0; j--)
                cout<<a[n][j];
            cout<<endl;
        }

    }
}
/*
import java.io.*;
import java.math.BigInteger;
import java.util.*;
public class Main
{
    public static void main(String[] args)
    {
       Scanner cin = new Scanner ( system.in );
       BigInteger arr[]=new BigInteger[300];
       arr[1]=BigInteger.ONE;
        arr[0]=BigInteger.ONE;
       arr[2]=BigInteger.valueOf(3);
       arr[3]=BigInteger.valueOf(5);
       for(int i=4;i<=270;i++){
    	   arr[i]=arr[i-2].multiply(BigInteger.valueOf(2));
    	   arr[i]=arr[i].add(arr[i-1]);
       }
    	int t;
       while(cin.hasNext()==true){
    	   t=cin.nextInt();
    	   System.out.println(arr[t].toString());    	   
       }
    }
}

*/

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐