微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

HDU - 1042 - N!大数阶乘

A HDU 1042.N!(大数阶乘)

Problem Description

Given an integer N(0 ≤ N ≤ 10000),your task is to calculate N!

Input

One N in one line,process to the end of file.

Output

For each N,output N! in one line.

Sample Input

1
2
3

Sample Output

1
2
6

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int main()
{
    int n;
    int res[70000];
    while (scanf("%d",&n)!=EOF){
        memset(res,0,sizeof(res));
        res[0] = 1;
        int j,len = 1;
        for (int i = 1; i <= n; i++){
            int c = 0;  
            for (j = 0; j < len; j++){
                res[j] = res[j]*i+c;
                if(res[j]>9){
                    c = res[j]/10;
                    res[j]%=10;
                }
                else    c = 0;
            }
            if (c){
                while(c){
                    res[j]=c%10;
                    c = c/10;
                    j++;
                    len++;
                }
            }
        }
        for(int i = len-1; i >= 0; i--)
            printf("%d",res[i]);
        printf("\n");
    }
    return 0;
}

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐