微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

hdoj 1397 Goldbach's Conjecture 大数素数打表


这道题本以为就是简单的合数分解,求素数组合数,没想到总是TLE,后来才发现里面的数范围特别大 2^15,所以只能打表了(把所有2^15以内素数标记为1,不是的标记为0)


Goldbach's Conjecture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5320    Accepted Submission(s): 2043


Problem Description
Goldbach's Conjecture: For any even number n greater than or equal to 4,there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2. 
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However,one can find such a pair of prime numbers,if any,for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number,the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1,p2) and (p2,p1) separately as two different pairs.
 

Input
An integer is given in each input line. You may assume that each integer is even,and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.
 

Output
Each output line should contain an integer number. No other characters should appear in the output.
 

Sample Input
  
  
6 10 12 0
 

Sample Output
  
  
1 2 1
 
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<iostream>
using namespace std;
#define max (1<<15)+10
bool prime[max];
void fun()
{
	memset(prime,1,sizeof(prime));
	for(int i=2;i<max;i++)
		for(int j=2;j<=sqrt(i);j++)
		{
			if(i%j==0)
			{
				prime[i]=0;
				break;	
			}
		}
		prime[0]=prime[1]=0;
}
/*void calcPrime()

{
    memset(prime,true,sizeof(prime));   //另一种达标方法,我试了下,比自己的还慢 
    for(int i=2; i<max; i++)
    {
       for(int j=i*2; j<max; j+=i) 
	   prime[j] = false;
    }
    prime[0] = prime[1] = false;
}*/

int main()
{	
	fun(); //必须调用先把素数标记出来,后边才能判断 
	int m,n;
	while(scanf("%d",&n)&&n)
	{    m=0;
		/*for(int i=2;i<=n/2 ;i++)
		{
			if(prime[i] && prime[n-i])
			{
			  m++;	
			}  
		}*/
		 
		 for(int i=2; i<=n/2; i++)

            if(prime[i] && prime[n-i]) m++;
            
		printf("%d\n",m);
	}
	return 0;
}

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐