微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

HDOJ 1002 A + B Problem II(大数)

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 260025    Accepted Submission(s): 50264


Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1004  1003  1008  1005  1089
思路:用数组处理大数问题,用p表示进位
注意格式:Case %d:\n      %s + %s = (空格问题)

#include<stdio.h>
#include<string.h>
int main(){
	int n,alen,blen,i,j=1,k,p=0;
	char a[1000],b[1000],c[1001];
	scanf("%d",&n);
	while(n){//不能是n--
		scanf("%s %s",a,b);
		printf("Case %d:\n",j);
		printf("%s + %s = ",b);
		alen=strlen(a)-1;
		blen=strlen(b)-1;
		for(k=0;alen>=0||blen>=0;alen--,blen--,k++){
			if(alen>=0&&blen>=0) c[k]=a[alen]+b[blen]-'0'+p;
			if(alen<0&&blen>=0) c[k]=b[blen]+p;
			if(alen>=0&&blen<0) c[k]=a[alen]+p;
			p=0;          //进位加上之后要清零
			if(c[k]>'9') { c[k]-=10;  p=1; }
		}
		if(p==1) printf("1");//最后的进位p=1
                while(k--) 
			printf("%c",c[k]);
		j++;        
		if(n!=1) printf("\n\n");
		else printf("\n");
		n--;//此处n--
	}
	return 0;
}

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐