微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

杭电1212 Big Number (大数求模运算)

Big Number

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5846 Accepted Submission(s): 4086

Problem Description

As we kNow,Big Number is always troublesome. But it’s really important in our ACM. And today,your task is to write a program to calculate A mod B.

To make the problem easier,I promise that B will be smaller than 100000.

Is it too hard? No,I work it out in 10 minutes,and my program contains less than 25 lines.

Input

The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000,and B will be smaller than 100000. Process to the end of file.

Output

For each test case,you have to ouput the result of A mod B.

Sample Input
2 3
12 7
152455856554521 3250
Sample Output
2
5
1521

Author
Ignatius.L

Source
杭电ACM省赛集训队选拔赛之热身赛

解题思想:
这道题是关于大数求模,算法思想在于:

abc%m=(a*100+b*10+c)%m
            =(a*100%m+b*10%m+c%m)%m

所以我们可以先求出10^1………10^Length of A 对m的求模结果,保存到N[1001]数组中。
然后,从个位开始分别按照公式求模,如果和大于m,再对和进行去模,一直循环下去可以得到结果。

代码如下:

#include<stdio.h>
#include<iostream>
using namespace std;
int N[1001];
char str[1001];
int main()
{
    int m,num=1,res;
    while(cin>>str>>m)
    {
        int len=strlen(str)-1;
        res=0;
        for(int i=0;i<=len;i++)
        {
          int x=str[len-i]-'0';
          num*=10;
          num%=m;
          if(i==0) num=1;
          N[i]=num;
          res+=x*N[i];
          if(res>m) res%=m; 
        }
        cout<<res<<endl;
    }
    return 0;
}

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1212

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐