微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

[HDU 2817]A sequence of numbers-大数

A sequence of numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4041    Accepted Submission(s): 1240


Problem Description
Xinlv wrote some sequences on the paper a long time ago,they might be arithmetic or geometric sequences. The numbers are not very clear Now,and only the first three numbers of each sequence are recognizable. Xinlv wants to kNow some numbers in these sequences,and he needs your help.
 

Input
The first line contains an integer N,indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence,and the last one is K,indicating that we want to kNow the K-th numbers of the sequence.

You can assume 0 < K <= 10^9,and the other three numbers are in the range [0,2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.
 

Output
Output one line for each test case,that is,the K-th number module (%) 200907.
 

Sample Input
  
  
2 1 2 3 5 1 2 4 5
 

Sample Output
  
  
5 16
#include <stdio.h>
#include <string.h>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include<queue>
#include<stack>
using namespace std;
const int MOD=200907;
int main()
{
	int n;
	__int64 a,b,c,k;
    scanf("%d",&n);
    while(n--)
    {
    	scanf("%I64d %I64d %I64d %I64d",&a,&b,&c,&k);
    	if(b-a==c-b)
    	{
    		printf("%I64d\n",(a%MOD+((k-1)%MOD)*((b-a)%MOD))%MOD);
    	}
    	else
    	{
    		__int64 ans=a;
    		__int64 temp=b/a;
    		k--;
    		while(k)
    		{
    			if(k&1)	ans=ans*temp%MOD;
    			temp=temP*temp%MOD;//temP*=temp%MOD  WA 
				k>>=1; 
    		}
    		printf("%I64d\n",ans%MOD);
    	}
    }
	return 0;
}

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐