微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

大数乘法C++

题目:POJ 2398

Bull Math
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13410   Accepted: 6903

Description

Bulls are so much better at math than the cows. They can multiply huge integers together and get perfectly precise answers ... or so they say. Farmer John wonders if their answers are correct. Help him check the bulls' answers. Read in two positive integers (no more than 40 digits each) and compute their product. Output it as a normal number (with no extra leading zeros). 

FJ asks that you do this yourself; don't use a special library function for the multiplication.

Input

* Lines 1..2: Each line contains a single decimal number.

Output

* Line 1: The exact product of the two input lines

Sample Input

11111111111111
1111111111

Sample Output

12345679011110987654321

Source



#include<iostream>
#include<cstring>
#include<cstdio>
#include<string>
using namespace std;

const int maxn = 100;
void reverse(char a[])
{
    int len = strlen(a);
    for(int i = 0 ; i < len / 2; i++)
    {
        int temp = a[i];
        a[i] = a[len - i - 1];
        a[len - i -1] = temp;
    }
}
int main()
{
    char a[maxn],b[maxn];
    int t[100] = {0};
    //printf("Please enter 2 numbers: ");
    scanf("%s%s",a,b);
    reverse(a);
    reverse(b);
    if(strcmp(a,"0")==0||strcmp(b,"0")==0)
        cout<<"0"<<endl;
    else
    {
        int i,j;
        for(i = 0; i <strlen(b); i++)
        {
            int cnt = 0;
            for(j = 0; j < strlen(a); j++)
            {
                int temp = (b[i] - '0') * (a[j] - '0');
                int tt= t[i+j] + temp + cnt;
                t[j+i] = tt % 10;
                cnt = tt / 10;
            }
            while(cnt != 0)
            {
                t[j+i] = cnt % 10;
                cnt = cnt / 10;
                j++;
            }
        }
        for(int k = i + j - 2; k >= 0; k--)
        {
            cout<<t[k];
        }
    }
    return 0;
}

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐