微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

hdu 1023 Train Problem II 这题运用到大数相乘+大数相除+卡特兰数

Train Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6454    Accepted Submission(s): 3514


Problem Description
As we all kNow the Train Problem I,the boss of the Ignatius Train Station want to kNow if all the trains come in strict-increasing order,how many orders that all the trains can get out of the railway.
 

Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.
 

Output
For each test case,you should output how many ways that all the trains can get out of the railway.
 

Sample Input
  
  
1 2 3 10
 

Sample Output
  
  
1 2 5 16796
Hint
The result will be very large,so you may not process it by 32-bit integers.
代码
#include <stdio.h>

int cat[110][100] ;

int main()
{
	int n ;
	cat[0][0] = cat[1][0] = 1 ;
	cat[0][1] = cat[1][1] = 1 ;
	for(int i = 2 ; i <= 100 ; ++i)
	{
		for(int j = 1 ; j <= cat[i-1][0] ; ++j)
		{
			cat[i][j] = cat[i-1][j]*(4*i-2) ;
		}
		int temp = 0,len = 1;
		for(len = 1 ; len <= cat[i-1][0] ; ++len)
		{
			cat[i][len] += temp ;
			temp = cat[i][len]/10 ;
			cat[i][len] %= 10 ; 
		}
		while(temp != 0)
		{
			cat[i][len++] += temp%10 ;
			temp /= 10 ;
		}
		for(int j = len-1,r = 0; j > 0 ; --j)
		{
			temp = r*10+cat[i][j] ;
			r = temp%(i+1) ;
			cat[i][j] = temp/(i+1) ;
		}
		while(cat[i][len] == 0)
		{
			--len ;
		}
		cat[i][0] = len ;
	}
	while(~scanf("%d",&n))
	{
		for(int i = cat[n][0] ; i > 0 ; --i)
			printf("%d",cat[n][i]) ;
		puts("") ;
	}
	return 0 ;
}

与君共勉

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐