微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

HDU - 1047 - Integer Inquiry 大数高精度

Integer Inquiry

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13969    Accepted Submission(s): 3523


Problem Description
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking varIoUs sums of those numbers. 
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment,once one became available on the third floor of the Lemon Sky apartments on Third Street.) 
 

Input
The input will consist of at most 100 lines of text,each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length,and will only contain digits (no VeryLongInteger will be negative). 

The final input line will contain a single zero on a line by itself.
 

Output
Your program should output the sum of the VeryLongIntegers given in the input. 


This problem contains multiple test cases!

The first line of a multiple input is an integer N,then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Sample Input
  
  
1 123456789012345678901234567890 123456789012345678901234567890 123456789012345678901234567890 0
 

Sample Output
  
  
370370367037037036703703703670
 

Source
 




简单大数题。。


AC代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

char a[110];
int ans[110];
int tmp[110];

void fun(char a[],int tmp[]) {
	int len = strlen(a);
	for(int i = len - 1; i >= 0 ; i--) {
		tmp[len - 1 - i] = a[i] - '0';
	}
}

void add(int ans[],int tmp[]) {
	int up = 0;
	for(int i = 0; i < 110; i++) {
		int t = ans[i] + tmp[i] + up;
		ans[i] = t % 10;
		up = t / 10;
	}
}

void print(int ans[]) {
	int flag = 0;
	for(int i = 109; i >= 0; i--) {
		if(ans[i] > 0) {
			flag = 1;
			printf("%d",ans[i]);
		}
		else if(flag && ans[i] == 0) printf("0");
	}
	if(flag == 0) printf("0");
	printf("\n");
}

int main() {
	int n;
	scanf("%d",&n);
	while(n--) {
		scanf("%s",a);
		if(strcmp(a,"0") == 0) {		//没判断只有一个0的情况,无语的WA了2次╮(╯▽╰)╭ 
			printf("0\n");
			if(n) printf("\n");
			continue;
		}
		memset(ans,sizeof(ans));
		fun(a,ans);
		
		while(1) {
			scanf("%s",a);
			if(strcmp(a,"0") == 0) break;
			memset(tmp,sizeof(tmp));
			fun(a,tmp);
			add(ans,tmp);
		}
		print(ans);
		if(n) printf("\n");
	}
	return 0;
}

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐