微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

POJ 1053 Integer Inquiry && HDOJ 1047 Integer Inquiry (大数加法)

题目链接(POJ):http://poj.org/problem?id=1503

题目链接(HDOJ):http://acm.hdu.edu.cn/showproblem.php?pid=1047


Integer Inquiry
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 30856   Accepted: 12007

Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking varIoUs sums of those numbers. 
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment,once one became available on the third floor of the Lemon Sky apartments on Third Street.) 

Input

The input will consist of at most 100 lines of text,each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length,and will only contain digits (no VeryLongInteger will be negative). 

The final input line will contain a single zero on a line by itself. 

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670

Source


题意:求n个大数之和

题解; 大数加法模板题——POJ和HDU上格式出处的要求稍有不同——HDOJ上的描述好混乱。

AC代码(POJ)

#include<iostream>
#include<cstring>
#include<string>
#define maxn 300
using namespace std;
int numx[maxn],numy[maxn],n;
string str,tmp;
string Add(string x,string y){
    string res="";
    memset(numx,sizeof(numx));
    memset(numy,sizeof(numy));
    int lenx=x.size(),leny=y.size();
    int maxlen=lenx>leny ? lenx:leny;
    for(int i=0;i<lenx;i++)numx[lenx-i-1]=x[i]-'0';
    for(int i=0;i<leny;i++)numy[leny-i-1]=y[i]-'0';
    for(int i=0;i<=maxlen;i++){
        numx[i]+=numy[i];
        if(numx[i]>9){
            numx[i+1]+=numx[i]/10;
            numx[i]%=10;
        }
    }
    int i=maxlen+2;
    for(;i>0&&!numx[i];)i--;
    for(;i>=0;i--)res+=numx[i]+'0';
    return res;
}
int main()
{
    string sum="0";
    while(cin>>str&&str!="0")
    sum=Add(sum,str);
    cout<<sum<<endl;
    return 0;
}


AC代码(HDU):

#include<iostream>
#include<cstring>
#include<string>
#define maxn 300
using namespace std;
int numx[maxn],leny=y.size();
    int maxlen=lenx>leny ? lenx:leny;
    for(int i=0;i<lenx;i++)numx[lenx-i-1]=x[i]-'0';
    for(int i=0;i<leny;i++)numy[leny-i-1]=y[i]-'0';
    for(int i=0;i<=maxlen;i++){
        numx[i]+=numy[i];
        if(numx[i]>9){
            numx[i+1]+=numx[i]/10;
            numx[i]%=10;
        }
    }
    int i=maxlen+2;
    for(;i>0&&!numx[i];)i--;
    for(;i>=0;i--)res+=numx[i]+'0';
    return res;
}
int main()
{
    while(cin>>n){
        while(n--){
                string sum="0";
            while(cin>>str&&str!="0"){
                sum=Add(sum,str);
            }
            cout<<sum<<endl;
            if(n)cout<<endl;
        }
    }
    return 0;
}

【转载请注明出处】

作者:MummyDing

出处:http://www.voidcn.com/article/p-oghcrafq-bbd.html

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐