微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

HDoj-1042 大数阶乘

N!
Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 53785    Accepted Submission(s): 15217

Problem Description
Given an integer N(0 ≤ N ≤ 10000),your task is to calculate N!


Input
One N in one line,process to the end of file.


Output
For each N,output N! in one line.

 
Sample Input
1
2
3
 

Sample Output
1
2
6

#include<stdio.h> 
#include<string.h>
const int maxn=50000;    //数组开到50000就可以满足10000的阶乘不越界 
int fun[maxn];
int main()
{
	int i,j,n;
	while(~scanf("%d",&n))
	{
 
	   memset(fun,sizeof(fun));
	   fun[0]=1;
	   for(i=2;i<=n;i++)          //从2的阶乘开始,一直到指定数的阶乘 
	   {
		   int c=0;
	    	for(j=0;j<maxn;j++)  //将所得阶乘数放在fun数组中,低位放在fun[0]中 
	    	{
			    int s=fun[j]*i+c;
		      	fun[j] =s%10;
		      	c=s/10;
	        }
       }
       
	  for(j=maxn-1;j>=0;j--)     //找出该数的最高位,即数组角码最大且不为0的数  
	           if(fun[j])  break;
	  for(i=j;i>=0;i--)  
	          printf("%d",fun[i]);
 	  printf("\n");
	}
	return 0;
}

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐