微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

ZOJ 3167大数乘小数的简单应用

题目链接http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=3199

Find 7 Faster Than John Von Neumann
Time Limit: 1 Second Memory Limit: 32768 KB

It was said that when testing the first computer designed by von Neumann,people gave the following problem to both the legendary professor and the new computer: If the 4th digit of 2^n is 7,what is the smallest n? The machine and von Neumann began computing at the same moment,and von Neumann gave the answer first.

Now you are challenged with a similar but more complicated problem: If the K-th digit of M^n is 7,what is the smallest n?

Input

Each case is given in a line with 2 numbers: K and M (< 1,000).

Output

For each test case,please output in a line the smallest n.

You can assume:

  1. The answer always exist.
  2. The answer is no more than 100.

Sample Input

3 2
4 2
4 3

Sample Output

15
21
11
AC代码

#include <stdio.h>
#include <string.h>
int a[300],b[300];
void mul(int i){
    int j,k;
    for(j=0;j<300;j++)
        b[j]*=i;
    for(i=k=0;i<300;i++){
        j=(b[i]+k)/10;
        b[i]=(b[i]+k)%10;
        k=j;
    }
}
int main(){
    int n,k,m,i,p;
    while(~scanf("%d%d",&k,&m)){
        memset(a,sizeof(a));
        memset(b,sizeof(b));
        p=m;
        n=1;
        for(i=0;p;i++){
            a[i]=b[i]=p%10;
            p/=10;
        }
        while(a[k-1]-7){
			mul(m);
            for(i=0;i<300;i++)
                a[i]=b[i];
            n++;
        }
        printf("%d\n",n);
    }
    return 0;
}

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐