微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

大数加法

A - 你会敲A+B吗?
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking varIoUs sums of those numbers. 
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment,once one became available on the third floor of the Lemon Sky apartments on Third Street.) 

Input

The input will consist of at most 100 lines of text,each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length,and will only contain digits (no VeryLongInteger will be negative). 

The final input line will contain a single zero on a line by itself. 

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670
 
   
代码张鑫提供
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
char a[1000];
int num[1000];
int main()
{
    memset(num,sizeof(num));
    int MAX=0,i;
    while(scanf("%s",a),strcmp(a,"0"))
    {
        if(strlen(a)>MAX)
        {
            MAX=strlen(a);
        }
        for(i=strlen(a)-1;i>=0;i--)
        {
            num[strlen(a)-1-i]+=a[i]-'0';
        }
        for(i=0;i<(MAX+10);i++)
        {
            if(num[i]>9)
            {
                num[i+1]+=num[i]/10;
                num[i]=num[i]%10;
            }
            else
            {
                num[i]=num[i];
            }
        }
    }
    int st;
        for(st=(MAX+10);st>=0;st--)
        {
            if(num[st]!=0)
            {
                break;
            }
        }
        if(st<0)
        {
            printf("0");
        }
        else
        {
            for(i=st;i>=0;i--)
            {
                printf("%d",num[i]);
            }
        }


        printf("\n");
    return 0;
}

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐