微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

UVA 10106 Product 大数相乘

Product 

The Problem

The problem is to multiply two integers X,Y. (0<=X,Y<10250)

The Input

The input will consist of a set of pairs of lines. Each line in pair contains one multiplyer.

The Output

For each input pair of lines the output line should consist one integer the product.

Sample Input

12
12
2
222222222222222222222222

Sample Output

144
444444444444444444444444


大数相乘,网上有很多模板,今下午练练手,自己写一遍,刚开始忽略了前置0,导致0*12=00,0*123=000,后来改了输出就ac了。

#include <iostream>
#include <cstring>
#define maxn 260
using namespace std;
int main()
{
    char str1[maxn],str2[maxn];
    while(cin>>str1>>str2)
	{		
		int len1,len2;
		len1=strlen(str1);
		len2=strlen(str2);
		
		int s1[maxn],s2[maxn];
		memset(s1,sizeof(s1));
		memset(s2,sizeof(s2));
		
		int i;
		for(i=0;i<len1;i++)
			s1[i]=str1[i]-'0';
		for(i=0;i<len2;i++)
			s2[i]=str2[i]-'0';
		
		int sum[maxn+maxn];
		memset(sum,sizeof(sum));
		int j,k;
		for(i=len2-1;i>=0;i--)
		{
			for(j=len1-1;j>=0;j--)
			{
				sum[i+j+1]=sum[i+j+1]+s2[i]*s1[j];
			}
		}
		for(k=len1+len2-1;k>=0;k--)
			if(sum[k]>=10)
			{
				int temp;
				temp=sum[k]%10;
				sum[k-1]=sum[k-1]+sum[k]/10;
				sum[k]=temp;
			}
			
			//if(sum[0]!=0)
			//	cout<<sum[0];
			bool flag=0;
			for(i=0;i<len1+len2-1;i++)
			{
				if(sum[i]!=0)
					flag=1;
				if(flag==1)
				cout<<sum[i];
			}
			cout<<sum[len1+len2-1];
			cout<<endl;
	}
    return 0;
}

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐