微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

HDOJ 题目1042 N!大数

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 53495    Accepted Submission(s): 15120


Problem Description
Given an integer N(0 ≤ N ≤ 10000),your task is to calculate N!
 

Input
One N in one line,process to the end of file.
 

Output
For each N,output N! in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 6
 

Author
JGShining(极光炫影)
题目大意:计算大数的阶乘
要点:数组开大些,,,,,又开小了,wa了一次
ac代码
#include<stdio.h>
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int i,a[100200],c,d=1,tc,j;
		a[1]=1;
		for(i=1;i<=n;i++)
		{
			for(j=1,c=0;j<=d;j++)
			{
				tc=a[j]*i+c;
				a[j]=tc%10;
				c=tc/10;
			}
			while(c)
			{
				a[++d]=c%10;
				c/=10;
			}
		}
		for(i=d;i>=1;i--)
			printf("%d",a[i]);
		printf("\n");
	}
}

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐