微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

HDOJ 题目1002A + B Problem II 大数

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 209712    Accepted Submission(s): 40343


Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 题目大意:大数的加法
ac代码
#include<stdio.h>
#include<string.h>
int main()
{
	int cot=0,n;
	char a[1010],b[1010];
	scanf("%d",&n);
	while(n--)
	{
	
		int c[1100],len1,len2,i,j,k=0,max;
		getchar();
		scanf("%s %s",a,b);
		len1=strlen(a);
		len2=strlen(b);
		i=len1-1;
		j=len2-1;
		memset(c,sizeof(c));
		while(i>=0||j>=0)
		{
			if(i<0&&j>=0)
				c[k]+=b[j]-'0';
			else
				if(i>=0&&j<0)
					c[k]+=a[i]-'0';
				else
					c[k]+=(a[i]-'0')+(b[j]-'0');
				k++;
				c[k]=c[k-1]/10;
				c[k-1]%=10;
				if(c[k])
					max=k;
				else
					max=k-1;
				j--;
				i--;
		}
		printf("Case %d:\n",++cot);
		printf("%s + %s = ",b);
		for(j=max;j>=0;j--)
			printf("%d",c[j]);
		printf("\n");
		if(n)
			printf("\n");
	}
}

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐