微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

HDU 1042 N! 阶乘大数

Problem Description
Given an integer N(0 ≤ N ≤ 10000),your task is to calculate N!
 

Input
One N in one line,process to the end of file.
 

Output
For each N,output N! in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2

6

代码

<pre name="code" class="java">import java.util.Scanner;
import java.math.BigInteger;  
public class Main {
	public static void main(String[] args) {
		Scanner cin= new Scanner(system.in);  //加快啥的
          int i;    
          int t;
          while(cin.hasNext()) //多重输入
          {
        	  t=cin.nextInt();    	
        	   BigInteger res=BigInteger.ONE;  
          for(i=2;i<=t;i++)
          {
        	  res=res.multiply(BigInteger.valueOf((long)i));     //将i的类型改为long 
          }
        	  System.out.println(res);
          }
	}
}
又一次证明JAVA的重要性 瞬间变水题啊 有木有。。

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐