微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

杭电1002 大数相加

http://acm.hdu.edu.cn/showproblem.PHP?pid=1002 

A + B Problem II


Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 第一次算大数相加,在网上看了思想,自己敲代码,由于粗心数组初始化出了点问题,提交了n次都没过,还好细心的队友发现啦!
#include<iostream>
#include<cstdio>
#include<string.h>
#define N 1005
int main()
{
	int i,j,k,m,l1,l2,t;
	char s1[N],s2[N];
	int a[N],b[N];
	scanf("%d",&t);
	for(m=1;m<=t;m++)
	{
		memset(s1,sizeof(s1));
		memset(s2,sizeof(s2));
		memset(a,sizeof(a));
		memset(b,sizeof(b));
		scanf("%s%s",&s1,&s2);
		l1=strlen(s1);
		l2=strlen(s2);
		if(l1>l2)
			k=l1;
		else
			k=l2;
		for(i=k,j=l1-1;j>=0;i--,j--)
			a[i]=s1[j]-'0';
		for(i=k,j=l2-1;j>=0;i--,j--)
			b[i]=s2[j]-'0';
		for(i=k;i>0;i--)
		{
			a[i]+=b[i];
			if(a[i]>=10)
			{
				a[i]=a[i]%10;
				a[i-1]++;
			}
		}
		printf("Case %d:\n%s + %s = ",s1,s2);
		if(a[0]!=0)
		{
			for(i=0;i<=k;i++)
			{
				printf("%d",a[i]);
			}
		}
		else
		{
			for(i=1;i<=k;i++)
				printf("%d",a[i]);
		}
		if(m<=t-1)
			printf("\n\n");
		else
			printf("\n");
	}
	return 0;
}

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐