微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

水题 hdu1002------用BigInteger解决大数问题

Problem Description
I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3
 
Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
import java.util.*;
import java.math.*;

public class Main3 {

	public static void main(String[] args) {
		Scanner sc=new Scanner(system.in);
		
		int t=Integer.parseInt(sc.next());
		for(int i=0;i<t;i++){
			BigInteger a=new BigInteger(sc.next());
			BigInteger b=new BigInteger(sc.next());
			BigInteger c=a.add(b);
			System.out.println("Case "+(i+1)+":");
			System.out.println(a+" "+"+"+" "+b+" "+"="+" "+c);
			if(i!=t-1)
			System.out.println();
		}
		
	}

}

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐