微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

TOJ 2424 POJ 2325 ZOJ 1923 Persistent Numbers /贪心 + 大数除法

Persistent Numbers

时间限制(普通/Java):1000MS/10000MS     运行内存限制:65536KByte

描述

The multiplicative persistence of a number is defined by Neil Sloane (Neil J.A. Sloane in The Persistence of a Number published in Journal of Recreational Mathematics 6,1973,pp. 97-98.,1973) as the number of steps to reach a one-digit number when repeatedly multiplying the digits. Example:

679 -> 378 -> 168 -> 48 -> 32 -> 6.

That is,the persistence of 679 is 6. The persistence of a single digit number is 0. At the time of this writing it is kNown that there are numbers with the persistence of 11. It is not kNown whether there are numbers with the persistence of 12 but it is kNown that if they exists then the smallest of them would have more than 3000 digits.
The problem that you are to solve here is: what is the smallest number such that the first step of computing its persistence results in the given number?

输入

For each test case there is a single line of input containing a decimal number with up to 1000 digits. A line containing -1 follows the last test case.

输出

For each test case you are to output one line containing one integer number satisfying the condition stated above or a statement saying that there is no such number in the format shown below.

样例输入

0
1
4
7
18
49
51
768
-1

样例输出

10
11
14
17
29
77
There is no such number.
2688

 

输入一个大数 求一个数的每一位乘起来等于它 而且要求尽可能小 贪心的思想 从9开始除 除的越大 最后就越小

#include <string>
#include <stdio.h>
#include <iostream>
using namespace std;
string str;
string temp;

int num(string a,int b)//大数相除的模板 
{
	string c;
	int k = 0,i;
	for(i = 0;i < a.size(); i++)
	{
		k *= 10;
		k += a[i]-'0';
		if(k/b||k/b==0&&c.size())
			c+=k/b+'0';
		k%=b;
	}
	temp = c;
	return k;
}

bool solve(string a)
{
	int i;
	for(i = 9; i >= 2; i--)
	{
		while(num(a,i)==0)
		{
			str += i+'0';
			a = temp;
		}
	}
	if(a=="1")
		return true;
	return false;
}
main()
{
	string a; 
	while(cin>>a,a!="-1")
	{
		if(a=="0"||a=="1")
		{
			cout<<"1"<<a<<endl;
			continue;
		}
		str = "";
		if(solve(a))
		{
			reverse(str.begin(),str.end());
			if(str.size()==1)
				cout<<"1";
			cout<<str<<endl;
		}
		else
			cout<<"There is no such number."<<endl;
	}
}

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐