微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

裴波那契大数相加问题

现在给你m个1,你可以把2个1组合成一个2

111 可以拆分为 111 、12、 21 有三种

输入

第一行输入一个n表示有n个测试数据
以下n行,每行输入m个1
(1 <= n,m <= 200)
输出
输出这种组合种数,占一行
样例输入
3
11
111
11111
样例输出
2
3
8


代码如下:

#include <cstdio>
#include<iostream>
#include<string>
using namespace std; 
int a[500],b[500];
int main()
{
	int n,i,j;
	scanf("%d",&n);
	while(n--)
	{
		string str;
		cin>>str;
		int len = str.size();
		if(len == 1)
		{
			printf("1\n");
			continue;
		}
		int tag = 0,cnt = 1,flag = 0,temp;
		memset(a,sizeof(a));
		memset(b,sizeof(b));
		a[0] = 1;
		b[0] = 1;
		for(i = 1; i < len; i++)
		{
			if(flag == 0)
			{
				for(j = 0; j < cnt; j++)
				{
					temp = a[j] + b[j] + tag;
					a[j] = temp % 10;
					tag = temp / 10;
				}
				if(tag)
				{
					a[cnt] = tag;
					tag = 0; 
					cnt++;
				}
				flag = 1;
			}
			else
			{
				for(j = 0;j < cnt; j++)
				{
					temp = a[j] + b[j] + tag;
					b[j] = temp % 10;
					tag = temp / 10;
				}
				if(tag)
				{
					b[cnt] = tag;
					tag = 0; 
					cnt++;
				}
				flag = 0;
			}
		}
		if(flag == 0)
		{
			for(i = cnt-1; i >= 0; --i)
				printf("%d",b[i]);
			printf("\n");
		}
		else
		{
			for(i = cnt - 1; i >= 0; --i)
				printf("%d",a[i]);
			printf("\n");
		}
	}
	return 0;
 }

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐