代码给出问题的运行时错误 给定范围内的最大异或对

如何解决代码给出问题的运行时错误 给定范围内的最大异或对

我正在尝试解决一个众所周知的问题,称为给定范围内的最大异或对。如果你不知道这个问题,这里是给我的提示:

You are given an array and Q queries of two types.
Type 0: Given a number x,insert the number at the last of the array.
Type 1: Given a number X and two integers L,R,Find a number Y in the range L,R to maximize X ^ Y

Input Format
First line of the test case will be the number of queries Q . Then on next Q subsequent lines you will be given a query either of type 0 or type 1. Query of type 0 is of the form : 0 X,where X is the integer to be inserted . Query of type 1 is of the form : 1 L R X

Constraints
0 <= element of array <= 10^9
1 <= N <= 10^5

Output Format
For each query of type 1 output the desired value.

Sample Input
5
0 3 
0 5
0 10 
0 6 
1 1 4 6
Sample Output
10

我正在使用 Tries 找出给定问题的最大 XOR,由于某种原因,它在 2 个测试用例中给出了运行时错误。我不知道为什么会这样。请帮忙!

这是我的代码:

#include<bits/stdc++.h>

using namespace std;

class node {
public:
    int index;
    node * left; // data = 0
    node * right; // data = 1
};

class Trie {
    node * root;
public:
    Trie() {
        root = new node();
    }

    void insert(int n,int idx) {
        // ith bit of a number is (n >> i) & 1
        node * temp = root;
        for(int i = 31; i >= 0; i--) {
            int bit = (n >> i) & 1;
            if(bit == 0) {
                if(temp->left == NULL) {
                    temp->left = new node();
                    temp->index = idx;
                }
                temp = temp->left;
            }
            else {
                if(temp->right == NULL) {
                    temp->right = new node();
                    temp->index = idx;
                }

                temp = temp->right;
            }
        }
    }

    int max_xor_helper(long long int value,int L,int R) {
        node * temp = root;
        long long int current_ans = 0;
        for(int j = 31; j >= 0; j--) {
            int bit = (value >> j) & 1;
            if(bit == 0) {
                // finding complimentary value
                if(temp->right != NULL and temp->index >= L and temp->index <= R) {
                    temp = temp->right;
                    current_ans += (1 << j); // 2 ^ j
                }
                else {
                    temp = temp->left;
                }
            }
            else {
                if(temp->left != NULL and temp->index >= L and temp->index <= R) {
                    temp = temp->left;
                }
                else {
                    temp = temp->right;
                    current_ans += (1 << j);
                }
            }
        }

        return current_ans;
    }
};


int maxXORPair(Trie root,int R,int X) {
    // Trie root;
    // int max_xor = 0,max_xor_partner = 0;
    // for(int i = L; i <= R; i++) {
    //  int val = arr[i];
    //  root.insert(val);
    //  int curr_ans = root.max_xor_helper(X,L,R);
    //  if(curr_ans > max_xor) {
    //      max_xor_partner = curr_ans ^ val;
    //      max_xor = curr_ans;
    //  }
    // }

    return root.max_xor_helper(X,R);
}

int main() {
    Trie root;
    int idx = 0;
    // vector<int> v;
    int queries;
    cin>>queries;
    for(int i = 0; i < queries; i++) {
        int type;
        cin>>type;
        if(type == 0) {
            long long int val;
            cin>>val;
            root.insert(val,idx);
            idx++;
            // v.push_back(val);
        }
        else {
            int L,R;
            cin>>L>>R;
            long long int X;
            cin>>X;

            long int ans = maxXORPair(root,X);
            cout<<ans<<endl;
        }
    }
    return 0;
}

解决方法

见:https://www.learncpp.com/cpp-tutorial/null-pointers

就像普通变量一样,指针在实例化时不会被初始化。

初始化指向 NULL 的指针。

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐


使用本地python环境可以成功执行 import pandas as pd import matplotlib.pyplot as plt # 设置字体 plt.rcParams[&#39;font.sans-serif&#39;] = [&#39;SimHei&#39;] # 能正确显示负号 p
错误1:Request method ‘DELETE‘ not supported 错误还原:controller层有一个接口,访问该接口时报错:Request method ‘DELETE‘ not supported 错误原因:没有接收到前端传入的参数,修改为如下 参考 错误2:cannot r
错误1:启动docker镜像时报错:Error response from daemon: driver failed programming external connectivity on endpoint quirky_allen 解决方法:重启docker -&gt; systemctl r
错误1:private field ‘xxx‘ is never assigned 按Altʾnter快捷键,选择第2项 参考:https://blog.csdn.net/shi_hong_fei_hei/article/details/88814070 错误2:启动时报错,不能找到主启动类 #
报错如下,通过源不能下载,最后警告pip需升级版本 Requirement already satisfied: pip in c:\users\ychen\appdata\local\programs\python\python310\lib\site-packages (22.0.4) Coll
错误1:maven打包报错 错误还原:使用maven打包项目时报错如下 [ERROR] Failed to execute goal org.apache.maven.plugins:maven-resources-plugin:3.2.0:resources (default-resources)
错误1:服务调用时报错 服务消费者模块assess通过openFeign调用服务提供者模块hires 如下为服务提供者模块hires的控制层接口 @RestController @RequestMapping(&quot;/hires&quot;) public class FeignControl
错误1:运行项目后报如下错误 解决方案 报错2:Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.8.1:compile (default-compile) on project sb 解决方案:在pom.
参考 错误原因 过滤器或拦截器在生效时,redisTemplate还没有注入 解决方案:在注入容器时就生效 @Component //项目运行时就注入Spring容器 public class RedisBean { @Resource private RedisTemplate&lt;String
使用vite构建项目报错 C:\Users\ychen\work&gt;npm init @vitejs/app @vitejs/create-app is deprecated, use npm init vite instead C:\Users\ychen\AppData\Local\npm-
参考1 参考2 解决方案 # 点击安装源 协议选择 http:// 路径填写 mirrors.aliyun.com/centos/8.3.2011/BaseOS/x86_64/os URL类型 软件库URL 其他路径 # 版本 7 mirrors.aliyun.com/centos/7/os/x86
报错1 [root@slave1 data_mocker]# kafka-console-consumer.sh --bootstrap-server slave1:9092 --topic topic_db [2023-12-19 18:31:12,770] WARN [Consumer clie
错误1 # 重写数据 hive (edu)&gt; insert overwrite table dwd_trade_cart_add_inc &gt; select data.id, &gt; data.user_id, &gt; data.course_id, &gt; date_format(
错误1 hive (edu)&gt; insert into huanhuan values(1,&#39;haoge&#39;); Query ID = root_20240110071417_fe1517ad-3607-41f4-bdcf-d00b98ac443e Total jobs = 1
报错1:执行到如下就不执行了,没有显示Successfully registered new MBean. [root@slave1 bin]# /usr/local/software/flume-1.9.0/bin/flume-ng agent -n a1 -c /usr/local/softwa
虚拟及没有启动任何服务器查看jps会显示jps,如果没有显示任何东西 [root@slave2 ~]# jps 9647 Jps 解决方案 # 进入/tmp查看 [root@slave1 dfs]# cd /tmp [root@slave1 tmp]# ll 总用量 48 drwxr-xr-x. 2
报错1 hive&gt; show databases; OK Failed with exception java.io.IOException:java.lang.RuntimeException: Error in configuring object Time taken: 0.474 se
报错1 [root@localhost ~]# vim -bash: vim: 未找到命令 安装vim yum -y install vim* # 查看是否安装成功 [root@hadoop01 hadoop]# rpm -qa |grep vim vim-X11-7.4.629-8.el7_9.x
修改hadoop配置 vi /usr/local/software/hadoop-2.9.2/etc/hadoop/yarn-site.xml # 添加如下 &lt;configuration&gt; &lt;property&gt; &lt;name&gt;yarn.nodemanager.res