微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

hdoj57718【Oracle】

Oracle

Time Limit: 8000/4000 MS (Java/Others)Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 738Accepted Submission(s): 322


Problem Description
There is once a king and queen,rulers of an unnamed city,who have three daughters of conspicuous beauty.

The youngest and most beautiful is Psyche,whose admirers,neglecting the proper worship of the love goddess Venus,instead pray and make offerings to her. Her father,the king,is desperate to kNow about her destiny,so he comes to the Delphi Temple to ask for an oracle.

The oracle is an integer n without leading zeroes.

To get the meaning,he needs to rearrange the digits and split the number into <b>two positive integers without leading zeroes</b>,and their sum should be as large as possible.

Help him to work out the maximum sum. It might be impossible to do that. If so,print `Uncertain`.

Input
The first line of the input contains an integer T (1T10) ,which denotes the number of test cases.

For each test case,the single line contains an integer n (1n<1010000000) .

Output
For each test case,print a positive integer or a string `Uncertain`.

Sample Input
  
  
3 112 233 1

Sample Output
  
  
22 35 Uncertain
Hint
In the first example,it is optimal to split $ 112 $ into $ 21 $ and $ 1 $,and their sum is $ 21 + 1 = 22 $. In the second example,it is optimal to split $ 233 $ into $ 2 $ and $ 33 $,and their sum is $ 2 + 33 = 35 $. In the third example,it is impossible to split single digit $ 1 $ into two parts.

Source

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<queue>
#include<list>
#include<algorithm>
#include<vector>
#include<cmath>
using namespace std;
const int maxn = 10000010;
char str[maxn];
int num[10];
int ans[maxn];
int main()
{
    int t,n;cin>>t;
    while(t--){
        scanf("%s",str);
        n=strlen(str);
        memset(num,sizeof(num));
        for(int i=0;i<n;++i){
            num[str[i]-'0']++;
        }
        if(n-num[0]<=1){
            printf("Uncertain\n");
            continue;
        }
        int cnt,x=0;
        for(int i=1;i<=9;++i){
            if(num[i]){
                cnt=i;num[i]--;break;
            }
        }
        for(int i=0;i<=9;++i){
            while(num[i]){
                if(i+cnt>=10){
                    int q=(i+cnt)%10;
                    ans[x++]=q;num[i]--;cnt=1;
                }
                else {
                    ans[x++]=i+cnt;
                    num[i]--;cnt=0;break;
                }
            }
            if(cnt==0)break;
        }if(cnt)ans[x++]=1;
        for(int i=9;i>=0;--i){
            while(num[i])printf("%d",i),num[i]--;
        }
        for(int i=x-1;i>=0;--i){
            printf("%d",ans[i]);
        }
        printf("\n");
    }
    return 0;
}

原文地址:https://www.jb51.cc/oracle/213503.html

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐