微信公众号搜"智元新知"关注
微信扫一扫可直接关注哦!

as easy problem

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16297    Accepted Submission(s): 10937


Problem Description
we define f(A) = 1,f(a) = ⑴,f(B) = 2,f(b) = ⑵,... f(Z) = 26,f(z) = ⑵6;
Give you a letter x and a number y,you should output the result of y+f(x).
 

Input
On the first line,contains a number T.then T lines follow,each line is a case.each case contains a letter and a number.
 

Output
for each case,you should the result of y+f(x) on a line.
 

Sample Input
6 R 1 P 2 G 3 r 1 p 2 g 3
 

Sample Output
19 18 10 ⑴7 ⑴4 ⑷
 


#include<stdio.h>

main()
{
char c;
int a,b,d,s,n,w,i,q;
scanf(%d,&q);
getchar();
//while(n--)
for(i=0;i<q;i++)
{
scanf(%c%d,&c,&s);
if(c>='A'&&c<='Z')
{a=c-'0'⑴6;
w=a+s;
//printf(%d ,w);
}
//continue;
if(c>='a'&&c<='z')
    {b=c-'0';
    b=b⑷8;
    a=-b;
   w=a+s;
   //printf(%d ,w);
//continue;
}
printf(%d ,w);
getchar();
}
  
return 0;
}

版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。

相关推荐