区间DP
Dire Wolf
Time Limit: 5000/5000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)Total Submission(s): 44 Accepted Submission(s): 30
Problem Description
Dire wolves,also kNown as Dark wolves,are extraordinarily large and powerful wolves. Many,if not all,Dire Wolves appear to originate from Draenor.
Dire wolves look like normal wolves,but these creatures are of nearly twice the size. These powerful beasts,8 - 9 feet long and weighing 600 - 800 pounds,are the most well-kNown orc mounts. As tall as a man,these great wolves have long tusked jaws that look like they Could snap an iron bar. They have burning red eyes. Dire wolves are mottled gray or black in color. Dire wolves thrive in the northern regions of Kalimdor and in Mulgore.
Dire wolves are efficient pack hunters that kill anything they catch. They prefer to attack in packs,surrounding and flanking a foe when they can.
― Wowpedia,Your wiki guide to the World of Warcra
Matt,an adventurer from the Eastern Kingdoms,meets a pack of dire wolves. There are N wolves standing in a row (numbered with 1 to N from left to right). Matt has to defeat all of them to survive.
Once Matt defeats a dire wolf,he will take some damage which is equal to the wolf’s current attack. As gregarIoUs beasts,each dire wolf i can increase its adjacent wolves’ attack by bi. Thus,each dire wolf i’s current attack consists of two parts,its basic attack ai and the extra attack provided by the current adjacent wolves. The increase of attack is temporary. Once a wolf is defeated,its adjacent wolves will no longer get extra attack from it. However,these two wolves (if exist) will become adjacent to each other Now.
For example,suppose there are 3 dire wolves standing in a row,whose basic attacks ai are (3,5,7),respectively. The extra attacks bi they can provide are (8,2,0). Thus,the current attacks of them are (5,13,9). If Matt defeats the second wolf first,he will get 13 points of damage and the alive wolves’ current attacks become (3,15).
As an alert and resourceful adventurer,Matt can decide the order of the dire wolves he defeats. Therefore,he wants to kNow the least damage he has to take to defeat all the wolves.
Dire wolves look like normal wolves,but these creatures are of nearly twice the size. These powerful beasts,8 - 9 feet long and weighing 600 - 800 pounds,are the most well-kNown orc mounts. As tall as a man,these great wolves have long tusked jaws that look like they Could snap an iron bar. They have burning red eyes. Dire wolves are mottled gray or black in color. Dire wolves thrive in the northern regions of Kalimdor and in Mulgore.
Dire wolves are efficient pack hunters that kill anything they catch. They prefer to attack in packs,surrounding and flanking a foe when they can.
― Wowpedia,Your wiki guide to the World of Warcra
Matt,an adventurer from the Eastern Kingdoms,meets a pack of dire wolves. There are N wolves standing in a row (numbered with 1 to N from left to right). Matt has to defeat all of them to survive.
Once Matt defeats a dire wolf,he will take some damage which is equal to the wolf’s current attack. As gregarIoUs beasts,each dire wolf i can increase its adjacent wolves’ attack by bi. Thus,each dire wolf i’s current attack consists of two parts,its basic attack ai and the extra attack provided by the current adjacent wolves. The increase of attack is temporary. Once a wolf is defeated,its adjacent wolves will no longer get extra attack from it. However,these two wolves (if exist) will become adjacent to each other Now.
For example,suppose there are 3 dire wolves standing in a row,whose basic attacks ai are (3,5,7),respectively. The extra attacks bi they can provide are (8,2,0). Thus,the current attacks of them are (5,13,9). If Matt defeats the second wolf first,he will get 13 points of damage and the alive wolves’ current attacks become (3,15).
As an alert and resourceful adventurer,Matt can decide the order of the dire wolves he defeats. Therefore,he wants to kNow the least damage he has to take to defeat all the wolves.
Input
The first line contains only one integer T,which indicates the number of test cases. For each test case,the first line contains only one integer N (2 ≤ N ≤ 200).
The second line contains N integers ai (0 ≤ ai ≤ 100000),denoting the basic attack of each dire wolf.
The third line contains N integers bi (0 ≤ bi ≤ 50000),denoting the extra attack each dire wolf can provide.
The second line contains N integers ai (0 ≤ ai ≤ 100000),denoting the basic attack of each dire wolf.
The third line contains N integers bi (0 ≤ bi ≤ 50000),denoting the extra attack each dire wolf can provide.
Output
For each test case,output a single line “Case #x: y”,where x is the case number (starting from 1),y is the least damage Matt needs to take.
Sample Input
2
3
3 5 7
8 2 0
10
1 3 5 7 9 2 4 6 8 10
9 4 1 2 1 2 1 4 5 1
Sample Output
Source
2014ACM/ICPC亚洲区北京站-重现赛(感谢北师和上交)
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int INF = 0x3f3f3f3f;
int n;
int a[222],b[222];
int dp[222][222];
int dfs(int l,int r)
{
if(l+1>=r) return dp[l][r]=0;
if(dp[l][r]!=⑴) return dp[l][r];
dp[l][r]=INF;
for(int i=l+1;i<r;i++)
{
dp[l][r]=min(dp[l][r],dfs(l,i)+dfs(i,r)+a[i]+b[l]+b[r]);
}
return dp[l][r];
}
int main()
{
int T_T,cas=1;
scanf(%d,&T_T);
while(T_T--)
{
int sum=0;
scanf(%d,&n);
for(int i=1;i<=n;i++)
scanf(%d,a+i);
for(int i=1;i<=n;i++)
scanf(%d,b+i);
memset(dp,⑴,sizeof(dp));
printf(Case #%d: %d
,cas++,dfs(0,n+1));
}
return 0;
}
版权声明:本文内容由互联网用户自发贡献,该文观点与技术仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 dio@foxmail.com 举报,一经查实,本站将立刻删除。